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Preface:

SSL-VPN is used for computers that have high-speed Internet access and that are not connected
to the New York State network through other means. SSL-VPN allows limited access to the New
York State computer network to enable use of the CONNECTIONS application. SSL-VPN stands
for “Secure Sockets Layer-Virtual Private Network.” The intention of the guide is to be useable by
any person attempting to install SSL-VPN to access CONNECTIONS. The guide is intended for
users who have a medium level of technical expertise, but should be useable as a “paint by
numbers” walkthrough even for those readers who are not as familiar with computers.

*These instructions assume that a PC with Windows 2000 or XP is being used with the Internet
Explorer web browser.

If at any point a message is displayed indicating “You do not have permission to log in.
Please contact your administrator,” please refer to the Temporary Internet Files/Cookies and
SSL-VPN Access for HSEN ID sections in the Troubleshooting/Configuration section appearing
later in this document.
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Java Installation

The first step in setting up your SSL-VPN connection is to ensure that the latest Java software is installed
on your PC. Java is a software platform that allows certain types of programs to run. Java may be
obtained by accessing the following website: http://java.sun.com. Follow the links to obtain the latest
Java client. If presented with several options, the latest JRE (Java runtime environment) for the
appropriate system platform should be downloaded and installed. In order to properly install Java an
administrator account for the PC is usually required.

Browser Configuration

After installing Java, open a web browser and input the following address: https://rcl.oft.state.ny.us/ocfs.
The following screen should display:

£]NY State Office for Technology - Microsoft Internet Explorer E@
File Edt ¥ew Favorites Tools Help 'IE.
@Back W > |ﬂ @ 7;\| /.-.'Search *v"( Favorites €ﬂ :.v ._% — %

Address i@ https:/frel oft,state, ny, usfdana-nalauthfurl_0jwelcome. cgi

Welcome to the
NY State Office for Technology
Username || Please sign in to begin your secure session.
Password |
.E]Done é 0 Inkernet

Figure 1: The SSL-VPN Login Screen

If this screen does not appear, the following screen, or one similar to it may display:
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Figure 2: ActiveX Control Prompt

é . Inkernet

The message at the top of the browser pane is indicating that the ActiveX control, an internet browser
based piece of code, that launches the Cache Cleaner, a component of SSL-VPN that clears temporary
files in your browser to maintain security, was prevented from automatically running. This is due to

restrictions established by the security settings in the browsing software.

The following permission dialog may also appear
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Figure 3: Cache Cleaner Permission Prompt

Click on the Always button to allow your browser to install the Juniper Networks Cache Cleaner, a
required component for SSL-VPN access.

The gray circle in front of the words Cache Cleaner shown above may also display as a red circle.
Additionally, an error message may display stating “You do not have permission to login. Please contact
your administrator” without displaying the Username and Password boxes (if these boxes are present
and you see this error message, the problem is possibly related to the HSEN UserIlD and will be
discussed later). This may happen due to an outdated version of Java being installed (although
completing the step regarding Java installation would rule this out) or because Java is not being allowed
to run properly as a result of restrictive browser security settings.

In Internet Explorer, the easiest way to set up the browser to allow Java and ActiveX for SSL-VPN access
is by taking the following steps:

From within Internet Explorer, go to Tools -> Internet Options -> Security. The following screen should
display:

Internet Options

| General | Security 'F_'rivqc:__l,l_ Content | Connections || Programs | Advanced

Select aWeb content zone to specify its security settings,

® € 0 o

Internet Local intranet  Trusted sites  Restricted
sites

Trusted sites
o This zohe containg Web sites that you  Gies. |
truzt ot ko damage your computer or
data. Mo sites are in this 20ne.
Security level for thiz zone

Custom
Custom settings.
- To change the settings, click Custom Level.
- To use the recommended settings, click Default Level.

| Custom Lewel... I I Default Level

[ Of H Canhcel I

Figure 4: The Security Tab

First, click on the green circle with the white checkmark in it above the words Trusted sites. Then click on
the Sites button, and type https://*.state.ny.us into the box where it says Add this Web site to the zone.
Click the Add button after this is accomplished, and the screen should now look like the following:
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https://*.state.ny.us/

Trusted sites @ |

‘ou can add and remove YWeb sites From this zone. All Web sites
in this zone will use the zone's security settings.

Add this Web site to the 2one:
et sites:

|https: H*’.’s’tate .U

Require server verification (https:) For all sites in this zone

I Custom Level... I | Default Level I
o]

Figure 5: The Trusted Sites Window

Click the OK button (which will close the above window), and then click on the Custom Level button on
the next screen. The following screen will display:

Security Settings @ anced

Settings:

. i NET Framewark-reliant comporients Rl
% Run components not signed with Authenticode
{_) Disable
e
(@) Enable
(_J) Prampt
% Run components signed with Authenticode [
() Disable
{3] Enable
'
. () Prampt
|§] Activer controls and plug-ins
@ Automatic prompting For Ackivel controls
{_ ) Disable
e’
() Enable

(17 S AP R L G B Pl

E2) - ()

Reset custom settings

Reset ko: Low ,. | Reset

L O, ]| Cancel ]

L]

L Iy T

Figure 6: The Security Settings Window

Ensure that the Low option is selected in the Reset to drop down list, and then press the Reset button. A
confirmation dialog will now appear. Press Yes on this confirmation screen (which will close the
confirmation dialog) and then the OK button again on the Security Settings screen pictured above.

The browser should now permit Java and ActiveX for all websites belonging to the secure state.ny.us
domain, including the Connections SSL-VPN access site.

Close out all open browser windows, then re-open the browser, and input the
https://rcl.oft.state.ny.us/ocfs address and the Username and Password entry boxes should display.
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Citrix Client Installation

The Citrix Presentation Agent (PN Agent) must be downloaded and installed in order to reach the
Connections application. This can be downloaded from within the SSL-VPN interface, after successfully
logging in to https://rcl.oft.state.ny.us/ocfs. After a valid HSEN login and password which has been
granted permission to access SSL-VPN has been entered, the following screen appears:

[E[ NY State Office for Technology - Home - Mictosoft Internet Explorer =J=lEd

file Edi View Favortes Tooks Help

eaack - \ﬂ @ ;’j /:;Seavch *Favorltes e 2 \; <] _|

Address €] httpsijfrcl oft state.ny.usfdanafhome findsx.coi

OFi

(4 b

Home Preferences Help | Sign out

Welcome to the NY State Office for Technology,

Warning: This systern and all dats accessed through it sre confidantisl and propristary to the Stats of New York, access is limitad ta suthorized emplayees and
lagally designated sgents. Unauthorized access to or relesse of State of Hew York systarns/dsta or other gavernment dsta may rasult in civil liability and/ar
criminal prosecution, Use of the systern, constitubes express consent for the State of Hew York to intercept, copy, and reuse any material entered an this

terminal. (Collapse)

web Bookmarks ||| ~|

Connections Application o
Click hare to sccass Connsctions Application

Wehbstar =
Click here to access Webstar Application,

http://www.ocfs.state.ny.us/ =]

http://ocfs.state.nyenet/ =

hitp://intra.ocfs.state.ny.us/ =]

sdssnets i

|

Windows Files

[@§ Citrix Client
Click here to download the Citrix dient,

client Application Sessions || |

#% Java Secure Application Manager =

Licenzad ko SASOHVAMIOFIESVR i s
Gopyright @ 2001-2005 Juniper Hetvorks, Tne, Juniper a‘w Net
All vights reserved,

&] Dore D @ Trusted sites

Figure 7: The Web Bookmarks Screen - Citrix Client Download

Scrolling to the bottom of that page displays a section entitled “Files”. In the files section, click on the
“Citrix Client” link. A page will now display with two files available for download, Citrix.exe and Citrix.zip.
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| @N\’Slme Office for Technology “Windows Files - Microsoft Internet ;-E).(plnrw g@
Fle Edt View Favortes Tools  Help i
@ Back = J |ﬂ |ﬂ ;"J /- ' Search "‘-:I'\_T Favorites Q‘} (ot _;,. ] e'u

Addre: @ https:)frcl.oft. skate ry.usidanaffbfsmbfwfb. coPt=piaw=1.11 10300372457 252 . D&si=08ti=08pi=0

liinks

GU

|

Help | Sign Dut

‘Browsing
| wiindows Files =

| Citrix Client\

Bookmarks
‘indows Files
Applications

citrix client |||
Client Applicat
. iant Applications o Type Size Madified
System.
-.'. Citrix axs Fila £216356 Bytas Tue Feb 8 08:13:32 2005
Prefarences
o — [ [ citriszio File ETET429 Byter Tue Feb & 08:12:44 2005
Licensed to MYS Office For Technology Juniper ﬂ\,'( Net
Copyright @ 2001-2004 Juniper Metworks, Inc All rights reserved,

:@ =1 ] Trusted sites

Figure 8: The Citrix.exe download link

Click on the Citrix.exe link. A prompt should now appear with the choices of Run, Save, or Cancel.
Select Save and download the file to a convenient location, such as the Windows Desktop or My
Documents folder.

The Citrix.exe file will now be downloaded and stored to that location. The download may take several

minutes to complete. Once the download has finished, navigate to the Citrix.exe file that was just
downloaded.
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J My Received Files g@
},—'

Fle Edit Wiew Favoites Tools  Help
"% o ®) .
O Back L ir p. Search || Folders El
File and Folder Tasks S @ Cltrix,exe
9 Make a new folder
g’ Fublish this Folder to the
Web

7 share this Folder

Other Places *

'_| My Documents
) Shared Dacumnents
_g My Computer

lg My Metwork Places

Details ¥

Figure 9: The downloaded Citrix.exe file

Double click on the Citrix.exe file, which should appear as above. Several windows will pop up and
disappear on their own, and after they complete, the PN Agent should be installed successfully,
completing this step. Note that it may be necessary to be logged in with administrative credentials to
successfully install the PN Agent.

Attempting to Access Connections

Once the above setup steps have been taken, the computer should now be properly configured for
accessing Connections.

Open Internet Explorer, and again go to https://rcl.oft.state.ny.us/ocfs, where the login screen will
appear.

[Note: If a message is displayed indicating, “You do not have permission to log in. Please contact your
administrator”, refer to the Temporary Internet Files/Cookies and SSL-VPN Access for HSEN ID sections
in the Troubleshooting/Configuration section appearing later in this document.]

The SSL-VPN login screen should now appear, and the next step will be to enter a valid HSEN UserID
and password and press the Enter key, or click the Sign In button. The following page will then load:
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£ hit =8|
Q- © \i] E] _;j ) search 5o Favories | 2 25 ]

i

Address | €] hitpsijrcd  oft. state.ny.usfdans/cs/plsasswait, cgi

EJGo Lrks

Launching the Secure Application Manager. Please wait...

Launching the Secure Application Manager may take several minutes, If an error prevents the Secure Application Manager fram loading properly, click here to continue. Mot all
functionality may he available.

&) Done

Figure 10: Launching the Secure Session Manager

This page will load the Secure Session Manager, which is hecessary for maintaining a secure connection

to the state network. The Secure Session Manager will appear in the lower right corner of the screen, as
shown in the above picture.

Do not click on the “click here to continue” link unless there has been an extremely long delay (over

two minutes) without the Secure Session Manager window appearing or signs of activity. Also do not
close the Secure Session Manager window when it appears.

[Note: If the Secure Session Manager window fails to appear, or a message is received indicating that a

Pop-up was blocked, refer to the Pop-up Blocking section in the Troubleshooting/Configuration section
appearing later in this document.]

After the Secure Session Manager loads, the Web Bookmarks page should be displayed. To get to
Connections, click on the Connections Application link, as shown below:
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File Edt View Favorkes Tooks  Help 7]

Q- © ¥ B & ) search ¢ Favorites () R- ;1 <

Address | hetps:frel oft state ny.usidana/home index.cgi

4 P © 10

Home Prefersnces | Help  Sign Out

Welcome to the NY State Office for Technology,
Warning: This systern and all data accessed through it are confidential and proprietary to the State of Hew York, access is limited to authorized employess and
legally designated agents, Unauthorized access to or release of State of Mew York systemns/data or other government data may result in civil liability and/or
criminal prosecution, Use of the system, canstitutes sxpress consent for the State of New York to intercept, copy, and reuse any material entered on this
terminal. (Collapse)

viub sookmarks ||

Connections Application =]
Click here to access Connections Application.
Wehstar =)
Click hera to access Webstar Application,
http:/ /www.ocfs.state.ny.us/ =]
http://ocfs.state .nyenet =}
http://intra.ocfs.state.ny.us =
dssnets =]

Windows Files

[ citrix Client
Click hars to dounload the Citrix disnt

Client Application Sessions -

% Java Secure Application Manager

Licensed to SASOHVAMIOFIESVR s
Copyright @ 2001-2005 Juniper Hetworks, [nc Jlll\lp!l a’o‘, Nt
All vights ressruad

&] Done 2 @ Trusted sites

Figure 11 - Selecting the Connections Application Link from the Web Bookmarks Page

A new window should be open, displaying another login screen and entitled Web Interface for MetaFrame

Presentation Server, as shown below:

MetaFrame Presentation Server - Microsoft Internet Explorer ===
File Edit View Favorites Tools  Help F o
ek - D =] [B] @0 | SO sewcn Ghpramie: £ | 3 e B
Address | 487 https:/jocfscitrixwi.ocks. state.ny. us/Citrix/Met aFr ame /default /deFault . aspx |

——
Web Interface for CiTR| x°
MetaFrame” Presentation Server o
Login Welcome
Please log in
Username: || 1
To log in to MetaFrame Presentation Server, enter the credentials required,
Password: | | and then click Log In.
—— | er =l If you do not know your login information, plesse contact wour help desk or
! system administrator.
Enable reconnect at login Message Center (ADPWI)
[Discornactad and Adiva Appiications =
The Message Center displays any informational or error messages that may
gEsur
&1 pone =) @ Trusted sites
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Figure 12: The Web Interface for MetaFrame Presentation Server login screen

[Note: If the Web Interface for MetaFrame Presentation Server window does not appear, and instead
there is a window with an error message stating “The page cannot be displayed” or “Action cancelled”
please refer to the Proxy Server Issues, Windows Issues, and Address Resolution Issues sections of the
Troubleshooting/Configuration section appearing later in this document.]

Enter the HSEN UserID and password of the person whose Connections session is to be accessed, and
then press the Enter key or click the Log In button.

A screen displaying several icons will appear, as shown below. The message stating “Your applications
have not been reconnected. Your farms do not support workspace control or do not trust the server”
appears, but may be ignored since it does not impact the ability to access Connections. [As a side note,
the term “farm” refers to a collection of servers.]

] MetaFrame Presentation Server - Microsoft Internet Explorer Q@ 3
File Edt Wiew Favortss Took Help i3
@ Back = ) g] ) ; - search 5 2 Favorites {4} - A
fddress | €] https:ffackscitrisys ocfs,skate . us{Citrix/MetaF ramejdefaulideFault, aspx v| B o

Web Interface for ci.l.RlxO
MetaFrame® Presentation Server .
Applications Ffe) Velome
& MetaFrame Presentation Server Applications
Top up
Welcome to your personalized view of MetaFrame Presentation Server
I = applications. The Applications box contains icons for the applications that you
= T can use. Click an icon to launch an application. Click Refresh to view the
Connections connections cannections latest applications. Click Settings to change your settings. Click a folder icon
Desktap 95 Desktap Full Preview to display its contents. If you have problems using an application, please
Percent Screen contact your help desk or system administrator for mare information.
t Message Center (AOPWI)
Connections Cannections QCFS Data The Message Center displays any informational or error messages that may
Training Training Warehouse occur,

Desktop 95% Desktop Full A
i o Your applications have not been reconnected. Your farms do not
L)

support waorkspace control or do not trust the server,

Recannect || Disconnect H Log Off |

& Done S @ Trusted sites
Figure 13: The Connections Application Icons screen

Select either the Connections Desktop 95 Percent or the Connections Desktop Full Screen icon. Both
icons will launch the Connections application, but in different resolution modes. The 95 Percent icon will
cause the Connections session to occupy 95% of the desktop, leaving the Windows toolbar and Start
Menu visible. In full screen mode, Connections will occupy the entire screen. Which display mode to use
is a matter of personal preference, however, if the desktop resolution is set a size less than 1024 by 768,
it may be necessary to use the full screen mode in order to view all buttons within Connections.

Upon clicking either of the icons, a progress indicator window will appear, as shown below.
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. CITRIX'

MetaFrame’ Presentation Server

Applications E ;m 7)) Welcome
ﬁm- s MetaFrame Presentation Server Applications
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applications, The Applications hog contains icons for the applications that you

L= i can use, Click an jcon to launch an application. Click Refresh to view the
Connections Cannections Connections latest applications, Click Settings to change your settings, Click a folder icon
Desktop 95 Desktop Full Preview to display its contents, If you have problems using an application, please
Percent Screen contact your help desk ar system administrator for more information,

Connecting to Connections Tr... B x

— er (AOPWI
Citrix’MetaFrame* i :

Connections r displays any informational or error messages that may

Training
Desktap Full | Preparing to conect...,

tions have not been reconnected. Your farms do not

space control or do not trust the server,

Reconnect H Disconnect H Log oOff

2] S @ Trusted sites
Figure 14: Indicator of Connections application launch progress

After the progress bar is filled, the Citrix session containing the Connections application will appear. After
clicking the OK button on the confidentiality notice that appears, the Connections desktop will appear, as
shown below.
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Figure 15: The Connections desktop

Clicking on the Connections icon will open the Connections toolbar, and the application is available for
use.

Troubleshooting/Additional Configuration

Temporary Internet Files and Cookies Issue
When attempting to login to the SSL-VPN login screen, an error message indicating, “You do not have
permission to login. Please contact your administrator” may appear before the login box is presented, as
shown below:

(& NY State Office for Technology - SSL - Mozilla Firefox =X

Ele Edit Yiew Go Bookmarks Tooks Help

43 - B - @ J @ ] hitpstffret oft.state. ny.usfdana-nafauthjurl_ofwelcome. coi x| © w0 |[GL

Welcome to the

NY State Office for Technology

You do not have permission to login. Please contact your administrator,

Dane rel.oft.state.ny.us 5

Figure 16: The Lack of Permission error message
This is caused by “congestion” in the temporary files stored by Internet Explorer. In order to remedy this,

go to Tools -> Internet Options. This will display the General settings tab. Press the Delete Cookies
button. A box will appear asking permission to delete all cookies, as shown below.
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Delete Cookies
Delete all cookies in the Temporary
! Internet Files Folder?
| ok J [ Cancel I

[ UseCument | [ OseLefaull | i Use Blank

Temporary [nternet files
bl Pages you view on the Internet are stored in a special folder
1 #

4 Mrograms | Advanced |

ome page.

for quick wviewing later,

[Delete Ecu:kie&...] | Delete Files... ] I Settings...

History

_T The Hiztary folder containg links to pages you've vigited, for
£ quick access to recently viewed pages.

Davs to keep pages in kistany: 20 % | Clear History

Calars. .. ] I Fantsz... | | Languanges... I |.-'lc:u:essibility...]

[ (1] 8 J[ Cancel ]

Figure 17: The Delete Cookies button and permission dialog
Press the OK button. This will close the dialog and return to the General settings tab.

Next press the Delete Files button. A dialog will appear asking permission to delete to temporary files, as
shown below.

Delete F“ES | Advanced

'j Delete all files in the Temporary Internet Files
L

You can also delete all vour offline content stored HA08,
locally,

Delete all offline content

i Blank

(o] 4 H Cancel I

7 ™y Pages you view on the Internet are stored in a special folder
Y@ Y for quick viewing later,

[Delete Eookies...l | Delete Files... ] | Sethings...

Higtamy

g The Hiztory folder containg links to pages you've wisited, for
8  guick access to recently viewed pages.

Drays to keep pages in hiztany: 20 $ Clear Histary

Colars. .. ] | Fontz.. | [ Languages... I [Accessibilit}l... ]

I ok H Cancel J
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Figure 18: The Delete Files Button and Delete Offline Content dialog

Check the check box for Delete all offline content, and then click the OK button. An hourglass may
appear and there may be a delay of several minutes while the temporary internet files are cleared. Wait
until the hourglass goes away.

Click on the OK button, which will close the Internet Options screen and return to the browser window.
Press the F5 key on the keyboard to refresh the screen, and the SSL-VPN login screen should appear. If
it does not, close all open browser windows and re-open Internet Explorer and go to
https://rcl.oft.state.ny.us/ocfs again. If this does not successfully display the login screen, repeat the
above steps and try once more.

Using the Sign Out button on the Web Bookmarks screen (shown below) when finished with Connections
will greatly reduce the occurrence of temporary internet file and cookie problems.

‘a MY State Office for Technology - Home - Microsoft Internet Explorer LT_]E]@
Eile Edt View Favorites Took Help wr
@ Back - () \ﬂ @ ;*, '/_ ) search j\/ Favorites 4} | [~ % (=] J
Acicss (] heps et of,state ny.usfdanafhomefindssx.ca v B0 s

OFT & P

Help

Welcome to the NY State Office for Technology,

Warning: This systern and all dats accessed through it are confidential and propristary to the State of Hew York, access is limited to autharized employees and
I=gally desianated sgents, Unauthorized access to or release of State of Hew York systems/data or other government data may result in civil liability and/or
criminal prozacution, Use of the system, constitutes sxprass consent for tha State of New York to intercept, copy, and reusze any matsrial entered on this

tarminal. (Collapse)

web Bookmarks ||| []

{& Connections Application

Click hera to accass Connactions Application,

]

HI.! Webstar
Click here to access Webstar Application,

(& http://www.ocfs.state.ny.us/
(& http://ocfs. state nyenet/

@ http://intra.ocfs.state.ny.us/
{& sdssnets

L o R s

Fies || [

Windows Files

[§ citrix Client
Click here to download the Citrix dient.

client Application sessions || |

& Jlava Secure application Manager Stant | 2=
Licensed to SASOHUAMIOFIESUR, i v
Copyright © 2001-2005 Juniper Networks, Inc JUBEP ST &‘w Ne:

All rights reserved,

&] Done B @ Trusted sites

Figure 19: The Sign Out button should be used when finished with Connections (see top right)

SSL-VPN Access for HSEN ID

If a user attempts to login to the SSL-VPN login window and receives the “You do not have permission to
login. Contact your administrator” error message, it indicates that the HSEN UserID for that user has not
been granted SSL-VPN access. Access can be granted by obtaining the application for SSL-VPN access
from http://ocfs.state.ny.us/main/vpn/sslvpn. The application form and instructions for completing it are
available at that link. The Security Coordinator, Local Security Administrator, or other authorized
requestor must submit the form.

Pop-up Blocking

Many pop-up blocking utilities will prevent the Secure Session Manager from opening. These pop-up
blockers can include the native Pop-Up Blocker contained in Internet Explorer, the Yahoo Toolbar, the
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Google Toolbar, or other third-party spam/pop-up/adware blocking software. These pop-up blockers
must either be disabled, or configured to allow the Secure Session Manager.

Most third-party toolbars have a setting to permit pop-ups for certain sites, but if that cannot be located,
the toolbar will need to be uninstalled or removed. This can usually be done by going to Start Menu ->
Settings -> Control Panel -> Add or Remove Programs and then selecting the offending toolbar and
choosing Remove. If the offending toolbar cannot be located in this listing, it may be necessary to contact
computer support personnel or the toolbar’'s vendor (e.g. Google, Yahoo, AOL).

Internet Explorer’s built in Pop-Up Blocker can be configured to allow the Secure Session Manager to
load from within Internet Explorer. Go to Tools -> Internet Options -> Privacy, which will display the
following screen if the version of Internet Explorer installed on this PC has built-in pop-up blocking.

Internet Options @ >

_GenEIaI Secuity | Privacy | Content | Connections | Programs | Advanced

Settings

e Move the slider to select a privacy zetting for the Internet

=@ =zone.

! Medium

- Blocks third-party cookies that do not have a compact
privacy policy

| - Blocks third-party cookies that use personally identifiable
L information without pour implicit consent

- Restricts first-party cookies that use personally identifiable
information without implicit conzent

[ Sites.. ” Impat... ”.-’-‘«dganced...l

Fop-up Blocker
Sj Prevent most pop-up windows from appearing.

Block pop-ups Settings...

[ DK _H Cancel ]

Figure 20: The Privacy Tab and Pop-Up Blocker Settings Button

Click on the Settings button, which will display the screen below.
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Pop-up Blocker Settings

E sceptions

Pop-ups are currently blocked. You can allow pop-upsz from specific
Wwieb zites by adding the site to the lizt below,

Address of \web site to allow:

" zhate ny Lz Add

Allowed gites:

Matifications and Filker Lewvel
Play a zound when a pop-up iz blocked.
Show |nformation Bar when a pop-up iz blocked.

Filter Level:

Mediurn: Block most automatic pop-ups e |
Pop-up Blocker FAT

Figure 21: The Pop-Up Blocker Settings window

Enter *.state.ny.us into the Address of Web site to allow box and then click on the Add button. Next, click
on the Close button, followed by the OK button on the next screen.

Internet Explorer should no longer prevent the Secure Session Manager window from opening. |If
something is still preventing the window from opening, continue to look for third-party software that may
be blocking pop-ups.

Windows Issues

If after clicking the Connections Application link on the Web Bookmarks page, a window appears and
states “The page cannot be displayed” or “Action cancelled”, it could possibly be the result of Windows
needing to be updated.

Windows can be updated by going to Start -> Windows Update and selecting Custom, followed by the
downloading and installation of all High Priority Updates and any Windows XP Updates listed under
Software, Optional. In order to run Windows Update, an administrative account for the local PC is usually
required. If the current account does not have administrative privileges, the LAN administrator or
computer support staff at the site may be able to perform the necessary steps or grant administrative
rights, if appropriate.

Proxy Server Issues
If the “Page cannot be displayed” or “Action cancelled” message is still appearing after clicking the
Connections Application link on the Web Bookmarks page, there may be an issue with the proxy server, a

tool used to filter out certain types of undesired internet traffic, at the site blocking access to Connections.

To set up Internet Explorer’s proxy setting to allow Connections access, go to Tools -> Internet Options ->
Connections. The following window will appear:
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Internet Options

General | Secury | Privacy | Content| Connections | Progiams | Advanced |

- Tosetupan Internet connection, click
'-_ Setup, B

Dial-up and Virtual Private Metwork seftings

Add...

Choose Settings if vou need to configure a proxy
server For a conneckion.

Lacal Area Metwark [LAN] zettings

LAM Settings do not apply to dial-up connections,
Choose Settings above For dial-up settings.

l 0k H Cancel H Apply J

Figure 22: The LAN Settings button on the Connections tab in Internet Explorer

Click on the LAN Settings button, and the following window will appear:

Local Area Hetwork (LAM) Settings

Automatic configuration

Automatic configuration may override manual settings. To ensure the
use of manual settings, disable automatic configuration,

[ ] automatically detect settings

|:| Use automatic configuration script

Prosey server

Use a proxy server For wour LAM (These settings will not apply to
dial-up or ¥PM connections),

Bddress: | KN, R Port: | 2080 \vanced. . &

=

Bypass proxy server for local addresses

[0]4 ‘ | Cancel

0K H Cancel H Apply
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Figure 23: The LAN Settings Window with Proxy Server enabled

If the “Use a proxy server for your LAN” box is not checked, there is no locally configurable proxy server
option that will resolve this issue. Do not check this box if it was not already checked, as it may disrupt
the network connectivity of the PC.

If the “Use a proxy server for your LAN” is checked, click on the Advanced button, and the window
pictured below will appear.

Proxy Settings E|@

Type Proxy address to use Port
HTTP: KRR AR RRA | &0a0
Secure:

FTP:

Gopher:

Socks:

IUse the same proxy server For all prokocols

Exceptions
Eﬂ__' Do niok use prowy server For addresses beaginning with:

4=

wE

*ikrix*
IUse semicolons (3 ) ko separate entries,

[ Ok, ][ Cancel I j

Figure 24: The Proxy Settings Window with *citrix* as an added exception

In the “Do not use proxy server for addresses beginning with:” box, type *citrix*. This will permit
Connections to bypass the proxy server and be able to be opened.

[Note: Do not make any other changes to the proxy server settings other than the one listed above. This
could affect internet connectivity on this PC.]

Finish this step by clicking the OK button on this screen followed by clicking the OK button on the next
screen. It may be necessary to close all open browser windows and re-open Internet Explorer after this
step.

Address Resolution Issues

If the “Page cannot be displayed” or “Action cancelled” message is still appearing after clicking the
Connections Application link on the Web Bookmarks page, there may be an issue with the network
configuration at the site blocking access to Connections.

A modification to the hosts file in Windows can sometimes fix this. Administrative access to the PC is
usually necessary to attempt this fix. Additionally, care must be taken when modifying the Hosts file, as it
can disable access to network resources if not configured properly.
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Open My Computer and navigate to C:\Windows\System32\Drivers\Etc. This will display the folder shown
below:

j C :\WINDOWS\systemSZ\drivers\etc
Edit

)

File: Tools  Help

@ Back = | >

Address ID CHWINDOWS\system3zt drivers) et

Yiew  Fawvorites

ﬁ‘ 7 ) search ‘[1_ Folders

&l
L =
v @ o

Falders
=) system3z
22 3com_dmi
1023 Imhasts,sam
J 10235 ] ::}\/I\B'I File
I 1031 b
) 1033 —
& i )
3 1041 2220 ke
) 1042 H—
) 1054 N p_rotocol
2 20=2 iiil ':":B
£ 3076
# ) appmgrit By services
hits aaal | Filz
CatRoot == e

) CatRootz

2 Com B
config |
[rata

Directis
dllcache
=) drivers
IL5) disdn
3 etc
[ export

Figure 25: The C:\Windows\System32\Drivers\Etc folder with Hosts file

Double-click on the file named Hosts. If prompted to choose what application is to be used to open this
file, select Notepad.

This will open the Hosts file, which will most likely appear as shown below:

& hosts - Motepad E]@
File Edit Format Wew Help

B Copyright (c) 1993-15%9 microsoft Carp.
#

# This is a sample HOSTS file used by Microsoft TCR/IP for windows.

# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual T1ine. The IP address should
# be placed in the first
# The IP address and the
# space.

column followed bg the corresponding host name.
host name should be separated by at Teast one

#
# additionall comments

{, (such as these) may be inserted on individual
# Tines or following the

machine name denoted by a '#' symbol.
i For example:
ﬁ 102.54.594.97 rhino. acme. com # source serwver
# 38.25.63.10 X, acme. com # x client host
127.0.0.1 Tlocalhost

Figure 26: The Unmodified Hosts file

Place the cursor below the last line in the Hosts file, which is the 127.0.0.1 line in this case. Next, type
the following without quotation marks “127.0.10.1 [Press the Tab key on the keyboard]
ocfscitrixwi.ocfs.state.ny.us”. The Hosts file should now appear as below:
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4 hosts - Notepad g@

File Edit Format Yiew Help
# Copyright (<) 1993-1999 Microsoft Corp.
#

# This is a sample HosTs file used by microsoft TCP/IP for windows.
*

# This file contains the mappings of IP addresses fo host names. Each

# entr¥ should be kept on an individual T1ine. The IF address should

# be placed in the first column followed bg the corresponding host name.
# The IP address and the host name should he separated by at least one
# space.

#+

# AddﬁtﬁonaTTX, comments (such as these) may be inserted on individual
# 1ines or following the machine name denoted by a '#' symhol.

For example:

38.25.63.10 X.acme. com # x client host

27.0.0.1 Tocalhost

#+
#
#
+ 102.54.94.97 rhino. acme. com # source server
#
1 :
127.0.10.1 ocfscitrixwi.ocfs.state. ny. us|

Figure 27: The Modified Hosts file

[Note: Do not modify or remove any lines already in the Hosts file. If there are more entries in the
Hosts file than the ones pictured above, that is fine. Incorrect changes to the Hosts file can cause
network resources to become unavailable.]

Go to File -> Save. Close all open browser windows, re-open Internet Explorer, and attempt accessing
Connections again. If this does not work, reboot the PC and try again.

If the same “Page cannot be displayed” or “Action cancelled” screen continues to appear, then the
problem lies somewhere in the connection between this site and the state network. The network
administrator for this site will need to be contacted, as it may be necessary to add permissions for access
to the ocfscitrixwi.ocfs.state.ny.us link to the firewall, routing tables, or proxy server of the agency
network.

Software Firewall Issues

For PCs with software firewalls installed (such as Zonealarm or Norton Internet Security), it may be
necessary to permit access to the internet for the Jupiter Networks Cache Cleaner component.

Typically, if a software firewall is uncertain how to process a request by the Cache Cleaner component to
access the internet, a prompt will be displayed asking whether to allow or deny access. There is usually
a check box to indicate that the software firewall should remember the decision. If this prompt appears
and there is an option to store the setting, select that option and choose to allow access.

If that option is not presented, please refer to the documentation for the software firewall being used to
determine the steps necessary to permit access of a specified component to the internet.

Adding Shortcuts to Connections

If Connections will be used frequently on this computer, it may be useful to create a shortcut to this
address on the Windows desktop or to save this address to the list of Favorites. This is not a required
step, but it may make getting to Connections easier for the person using this computer.

To save this address to the Favorites list, go to Favorites-> Add to Favorites. A prompt will appear
indicating that this address will be added to the list of Favorites under the name “New York State Office
for Technology”. This name can be renamed to anything that will make it easier to determine what this
link is to by replacing the “New York State Office for Technology” text with anything else, such as
“Connections” or “SSL-VPN Login”.

To place a shortcut to the SSL-VPN login screen on the Windows desktop, go to File -> Send -> Shortcut
to Desktop. An icon entitled “New York State Office for Technology” will now appear on the desktop. If
desired, right clicking on the icon and choosing Rename will enable the icon hame to be changed.
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Further Assistance

If you are still encountering problems using or configuring SSL-VPN, please contact the New York State
Enterprise Help Desk at (800) 697-1323. This resource is provided as a free service by New York State
and will not incur any costs to the agency or site.
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